My poor Blitz3d is broken


Tweet
(Posted 1 month ago) GrumpyOldMan

Hello

I was involved in the Blitzbasic forums a long, long time ago and I've come back to Blitz3d but it seems that something has been broken. I'm using a Windows 7 machine, and the machine and the graphics card had previously had no problem running any of my programs. But now it falls over in a heap. I get the 'Compiler Runtime error. Unable to open runtime.dll' error and now it fails to load textures that aren't square or in dds format. I've tried downloading newer versions - blitz3d_ng_v200-alpha.002, Blitz3d1106-1108 but I can't get them to work. I've had to take it back to 1.87 to get anything to work at all.

Is there any way to make it better?

Cheers, thanks for any help.

GrumpyOldMan

(Posted 1 month ago) RonTek commented:

Welcome to the Forums GrumpyOldMan!

Blitz3D 1.106 should work fine which I am using on Windows 7 for testing.

You can also check out the latest msvc2017 version here https://www.blitzcoder.org/forum/topic.php?id=32

(Posted 1 month ago) GrumpyOldMan commented:

Hello RonTek

Thanks for the reply.

I've gone back and checked everything, and tried reinstalling the various versions of Blitz3D but still no joy. I went back to an old laptop that had a running version, copied it over to a USB. It worked fine on the laptop and from the USB. I plugged it into the PC and tried it from the USB, still got the Compiler error, unable to open runtime.dll, same with transferred to hard drive.

DXdiag shows, DX11, DirectDraw Accel, Direct3D Accel and AGP Texture Accel all enabled on a GEForce GT710. Checked, have MSVC 2017 installed. Setup worked fine before.

Will try scrubbing everything Blitz3D from the PC and reinstalling. hopefully won't lose everything.

Edit: Nothing at all works now including the 1.87 that was working. Does it need to be turned back to MSVC 2015?

Edit 2: Walked it back to DX9.0c and things are working again. Obviously doesn't like DX11. Hope this helps somebody else with the same problem..

Cheers

GrumpyOldMan

(Posted 1 month ago) Blitzman commented:

Go here https://blitzresearch.itch.io/blitz3d download install.Done.

Grumpy why you say dx9/11.Blitz3d(origanal) is dx7 only.

(Posted 1 month ago) GrumpyOldMan commented:

Hello Blitzman

Yes Blitz3d is dx7 only but they must have amended and/or deleted something in dx11 that would allow a dx7 program to run properly. Not sure what or if that's the reason but reinstalling dx9.0c got rid of the compiler environment error. Maybe the MSVC was calling a routine that had been taken out of dx11??? Be interested to hear how everyone else is going with Blitz3d and various DX versions.

Incidentally, Avast AV is identifying Blitzcc.exe as idp.generic as a false positive virus now. There needs to be an exception noted for it within Avast and I'm assuming AVG since there from the same stable now.

Cheers

GrumpyOldMan

(Posted 1 month ago) RonTek commented:

For the record Blitz3D should still work with DX11 so perhaps do try switching your AV software to Security Essentials for Windows 7.

(Posted 1 month ago) Blitzman commented:

Oh i see what you mean now.I am running DX12 with win 10,and Blitz3d runs ok.Sorry mis understood.:)

Perhaps update your graphics card drivers.

Reply To Topic (minimum 10 characters)

Please log in to reply