Collision Response Bug?


👉 BlitzCoder will be building a new platform and other plans to preserve and continue the Blitz legacy.

To be able to achieve this goal, we need your support by becoming a Patreon Paid Member 👈

 

Tweet blitz3d bug
RasterRon

Run the Collisions command example under Global category.
For some reason Slide2 and Stop response type collisions don't seem to work, both still run as Slide1.

response - what the source entity does when a collision occurs. 
1: stop 
2: slide1 - full sliding collision 
3: slide2 - prevent entities from sliding down slopes 

perhaps this just occurs in this setup example or yet another possible recently discovered bug..?

CraigTheCoder commented:

I can confirm this behavior in the sample. Don't know what's up, but I usually don't reset collision parameters mid-loop either. Working on a platformer and can confirm that collisions work properly.

RemiD commented:

collisions responses stop or slide work well (from what i remember), you are doing something wrong.

RasterRon commented:

collisions responses stop or slide work well (from what i remember), you are doing something wrong.

Don't know what's up, but I usually don't reset collision parameters mid-loop either.

Yes, it seems to be the case with Blitz3D and works when it is fixed or in non-loop, so the example does not apply.

btw, with Blast3D the example works or collision responses can be changed dynamically.

RemiD commented:

one way to see the difference of behavior between the 3 collision responses, is to create a sphere with the same origine and radius than the ellipsoid, and to reposition the sphere after updateworld() has been called. (and maybe stop the movement of the ellipsoid after a collision has been detected, to better see the difference of each collision response.)

Reply To Topic (minimum 10 characters)

Please log in to reply