JoyPitch() and JoyYaw() not working?  


👉 BlitzCoder will be building a new platform and other plans to preserve and continue the Blitz legacy.

To be able to achieve this goal, we need your support by becoming a Patreon Paid Member 👈

 

Tweet gamepad
misterbull82

using BlitzMax NGE here and I cant seem to get JoyPitch() and JoyYaw() to work with my gamepads right joystick. JoyX() and JoyY() work just fine for the left joystick. I'm using a GameSir T4 Pro

BlitzCoder commented:

Have you tried testing it using vanilla blitzmax?

misterbull82 commented:

I dont have vanilla version on this pc, I have tested Blitz3D however and it detects the controller pitch and yaw just fine.

I also tried switching to my 8bitdo SN30 gamepad and it still did not seem to work.

And yeah, I've tested it on another computer with still no results :P

I'll try installing vanilla BMax here in a bit to see what happens

  misterbull82 commented:

Okay, I tried it on vanilla BMax and I can confirm it does not work there either.

Could this be a thing with newer gamepads maybe?

Again the pitch and yaw work just fine on vanilla Blitz3D, it just does not seem to work on BlitzMax vanilla or newer. :P

EDIT: Did some digging in the BlitzMax code documentation and found some revealing sample code. It seems I need to use the joyR() and JoyU() commands to get the right joystick readings :P

That about solves my problem, still annoying how that was changed from B3D to BMax.

BlitzCoder commented:

Reply To Topic (minimum 10 characters)

Please log in to reply